Welcome, Guest
Username: Password: Remember me

TOPIC: sabercore 3.0 troubleshooting

sabercore 3.0 troubleshooting 5 months 3 days ago #82275

  • Darth Roons
  • Darth Roons's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Thank you received: 1
i plug my ASP saber into the sabercore 3.0 editor to change some things. i save all settings, sound files, and burn to chip 100% done. unplug my saber and its complexly unresponsive. the power button stays lit up so i try plugging my saber back in the the editor and it will not pick up my saber. help please?
The administrator has disabled public write access.
The following user(s) said Thank You: Jaymz7

sabercore 3.0 troubleshooting 5 months 3 days ago #82277

  • Rhyno
  • Rhyno's Avatar
  • Offline
  • Platinum Member
  • MTFBWY
  • Posts: 452
  • Thank you received: 130
Darth Roons
Make a video showing the problem email Customer Service, they’ll fix you up.
There is no Light, There is no Dark, There is only the Force!
The administrator has disabled public write access.

sabercore 3.0 troubleshooting 5 months 3 days ago #82281

  • WyvernClaw
  • WyvernClaw's Avatar
  • Offline
  • Junior Member
  • Posts: 37
  • Thank you received: 21
This sounds like exactly what happened to my first one. Basically, the board has failed and it needs to be sent back to be replaced. Give others a little bit to chime in just in case there's an easier way, but if it won't connect at all, it seems like it's probably dead.
The administrator has disabled public write access.

sabercore 3.0 troubleshooting 4 months 4 weeks ago #82551

  • TOPACES
  • TOPACES's Avatar
  • Offline
  • Senior Member
  • Posts: 47
  • Thank you received: 26
Darth Roons wrote:
i save all settings, sound files, and burn to chip 100% done. unplug my saber and its complexly unresponsive. the power button stays lit up so i try plugging my saber back in the the editor and it will not pick up my saber. help please?

Hi Darth Roons,

I was just setting up my new saber with the editor yesterday and ended up with a similar error.

After the third "burn to chip" cycle, only the light and energy vibration is working, but sound is dead.
Is your saber completely dead (light as well), or also just the sound?

Also, did you contact customer support for troubleshooting? They may have some ideas for what to try out as well.
Last Edit: 4 months 4 weeks ago by TOPACES.
The administrator has disabled public write access.

sabercore 3.0 troubleshooting 3 months 2 weeks ago #84139

  • msauer189
  • msauer189's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Thank you received: 1
Hey guys. So it's been a few days for me since I've touch my saber. Received a new sabercore 3.0 for Christmas and today I noticed it only loads the one sound font and settings. Even when confirming the other 2 font selections the board only loads the one. Any others run into this problem? Solutions? I read on Reddit the board had to be returned. I was hoping maybe someone knew of a software update?
The administrator has disabled public write access.

sabercore 3.0 troubleshooting 3 months 2 weeks ago #84140

  • Rhyno
  • Rhyno's Avatar
  • Offline
  • Platinum Member
  • MTFBWY
  • Posts: 452
  • Thank you received: 130
msauer189
try This
There is no Light, There is no Dark, There is only the Force!
The administrator has disabled public write access.

sabercore 3.0 troubleshooting 3 months 6 days ago #84687

  • msauer189
  • msauer189's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Thank you received: 1
Thanks that helped!

Now I've just noticed that occasionally when striking the whole thing just shuts down. Just needs to be booted back up but kinda annoying. (I know my hand isn't hitting the switch as there's a whole switchguard around the activation button)
The administrator has disabled public write access.

Member Login

Latest Posts

    • Pre-Order Sabers Question... (1 Posts)
    • I know pre order sabers will have an extended period where they are placed upon the already existing...
    • Sabercore 3.0 (6 Posts)
    • Plug in your saber wait for the bzzt, then start the editor
    • Saber Forge April Sale!!!... (44 Posts)
    • Quote: To my german fellows: were you charged import taxes on your Lightsabers by the customs office? Not...
    • Sabercore3 not saving (5 Posts)
    • Hi, no I didn't change any of the sound fonts just the settings for sensitivity. I did try burning...

More Topics »

Forum Statistics

  • Total Users: 6834
  • Latest Member: reliken
  • Total Posts: 69.1k
  • Total Topics: 5823
  • Total Sections: 24
  • Total Categories: 145
  • Today Open: 4
  • Yesterday Open: 1
  • Today Answer: 26
  • Yesterday Answer: 19