Welcome, Guest
Username: Password: Remember me

TOPIC: Sabercore 3.0 Manual Installation

Sabercore 3.0 Manual Installation 3 months 2 weeks ago #83906

  • Dagorhir_Thalion
  • Dagorhir_Thalion's Avatar
  • Offline
  • New Member
  • Posts: 1
Recently bought the Emerald Knight Saber only with the blade with the 12v, LED quick charge add-ons (warrior tier essentially). I later decided to buy the sabercore 3.0 by itself to try and add it to the rest of the saber. Probably should have paid more to get the plug-and-play to make life easy, but I opted to solder instead.

Upon looking at the soundboard, I noticed a whole set of spots of potential places to connect the wires to. I'm also uncertain where to connect the soundboard to the saber correctly, I'm assuming it needs to be connected to the switch (it's been years since I've done hardwiring). From browsing the forums it doesn't look like there's a manual or any video elsewhere documenting how to manually install the sabercore 3.0.

Has anyone manually installed theirs or know of a good guide to follow?

Thanks!
The administrator has disabled public write access.

Sabercore 3.0 Manual Installation 3 months 2 weeks ago #84034

  • OvrcAHst
  • OvrcAHst's Avatar
  • Offline
  • Moderator
  • Posts: 3031
  • Thank you received: 1913
See if the following provides assistance..

The administrator has disabled public write access.

Member Login

Latest Posts

    • Assembling a staff (1 Posts)
    • I’m curious about assembling a staff with ASP. So, I need.... LED, Emitter, switch selector, body,...
    • Sith Lord Lightsabers (4 Posts)
    • Quote: 1: Those are absolutely beautiful. Good job collecting. 2: Why do you need to wear gloves? Do they...
    • Current ASP order lead ti... (48 Posts)
    • Last Friday I ended up emailing support about my order. (Small order to patch a problem with my...
    • VIRTUAL SABER BUILDER??? (11 Posts)
    • Working here sir. Sounds like some browser trouble. Have you tried another browser? (Just to test)...
    • VIRTUAL SABER BUILDER??? (11 Posts)
    • I tried many times to load the configure with no success using updated Google chrome. The screen...

More Topics »

Forum Statistics

  • Total Users: 6834
  • Latest Member: reliken
  • Total Posts: 69.1k
  • Total Topics: 5815
  • Total Sections: 24
  • Total Categories: 145
  • Today Open: 1
  • Yesterday Open: 2
  • Today Answer: 0
  • Yesterday Answer: 44